Fastadmin的JQ版本太老了被网安要求更换处理方法
摘要:一个客户用的Fastadmin框架开发的网站,最近没开Nginx防火墙,被网安扫描到说是jq版本太低让升级...
一个客户用的Fastadmin框架开发的网站,最近没开Nginx防火墙,被网安扫描到说是jq版本太低让升级...于是根据Fastadmin官方给出的方案,完成了JQ版本的升级!


第一步:直接用最新的JQ版本覆盖

第二步:添加代码块,并将backend.js和frontend.js里的.size()方法改为.length后重新打包即可。

宝塔面板需要安装下Node.js版本管理器,并设置好命令行版本,然后在根目录下执行打包命令即可。需要注意的是根目录下需要有think文件,否则会报错。
